const regex = new RegExp('(?<![a-z0-9&])[a-z][0-9](?![a-z0-9&])', 'gmi')
const str = `.A3 S3- D4(SPACE) D5/ E9R E0&`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}