$re = '/(?<![a-z0-9&])[a-z][0-9](?![a-z0-9&])/mi';
$str = '.A3 S3- D4(SPACE) D5/ E9R E0&';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);