$re = '/^(?:(?:tac)+|(?!.*(tictic))(?:tac){2,}tic(?:t[ia]c)*)$/m';
$str = 'tactactic
tactactictactic
tactactictactictactactictac
tac
tactactac
tic
tactactictactictictac
tactictac';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);