re = /^(?:(?:tac)+|(?!.*(tictic))(?:tac){2,}tic(?:t[ia]c)*)$/m
str = 'tactactic
tactactictactic
tactactictactictactactictac
tac
tactactac
tic
tactactictactictictac
tactictac'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end