#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)((anticorpi|ac|ciroza).*?)?(hepatita (cr(onica)? )?(.*?))?(vh|hv|virus )([bcd])(.*?(vh|hv|virus )([bcd]))?"
Local $sString = "HEPATITA CRONICA CU VHC" & @CRLF & _
"HEPATITA CRONICA - VHC" & @CRLF & _
"HEPATITA CRONICA DE ETIOLOGIE MIXTA NUTRITIONALA SI VHC" & @CRLF & _
"HEPATITA CRONICA CU VHC." & @CRLF & _
"HEPATITA CRONICA CU VHC." & @CRLF & _
"HEPATITA CRONICA CU VHC" & @CRLF & _
"HEPATITA CRONICA - VHB" & @CRLF & _
"HEPATITA CRONICA CU VIRUS C" & @CRLF & _
"HEPATITA CRONICA" & @CRLF & _
"HEPATITA CRONICA CU VHB" & @CRLF & _
"HEPATITA CRONICA MEDICAMENTOASA." & @CRLF & _
"HEPATITA DE ETIOLOGIE POSIBIL VIRALA IN APP" & @CRLF & _
"HEPATITA VIRUS C" & @CRLF & _
"HEPATITA CRONICA CU VHB" & @CRLF & _
"HEPATITA CRONICA CU VHC " & @CRLF & _
"Hepatita cr cu virus B" & @CRLF & _
"HEPATITA VIRUS C" & @CRLF & _
"HEPATITA VIRALA (VHA-####) " & @CRLF & _
"HEPATITA CRONICA VHB" & @CRLF & _
"HEPATITA CRONICA CU VHC" & @CRLF & _
"HEPATITA CRONICA- VHB" & @CRLF & _
"HEPATITA CRONICA CU VHC " & @CRLF & _
"HEPATITA CRONICA CU VHC(####)" & @CRLF & _
"HEPATITA CRONICA DE ETIOLOGIE NEPRECIZATA " & @CRLF & _
"HEPATITA CRONICA CU VHB" & @CRLF & _
"HEPATITA CRONICA VHC" & @CRLF & _
"HEPATITA CRONICA VIRALA CU VHC" & @CRLF & _
"HEPATITA VIRALA -VHC " & @CRLF & _
"HEPATITA CRONICA CU VHC" & @CRLF & _
"Hepatita cronica cu virus B" & @CRLF & _
"HEPATITA CRONICA CU VHB +VHC" & @CRLF & _
"HEPATITA CRONICA VHB+VHC " & @CRLF & _
"HEPATITA VIRALA C " & @CRLF & _
"HEPATITA CRONICA CU VHC " & @CRLF & _
"HEPATITA CRONICA CU VHB" & @CRLF & _
"HEPATITA CRONICA VHB+VHC" & @CRLF & _
"HEPATITA CRONICA CU VHB " & @CRLF & _
"HEPATITA B" & @CRLF & _
"Hepatita cronica." & @CRLF & _
"HEPATITA CRONICA CU VHB" & @CRLF & _
"CIROZA HEPATICA SECUNDARA INFECTIEI CU VHB SI VHD " & @CRLF & _
"CIROZA HEPATICA VHB +VHD" & @CRLF & _
"CIROZA HEPATICA SECUNDARA INFECTIEI CU VHB SI VHD" & @CRLF & _
"HVB, HVC " & @CRLF & _
"HVB+ HVC " & @CRLF & _
"HVC + HVB " & @CRLF & _
"HEPATITA CU HVC " & @CRLF & _
"HEPATITA CRONICA HVC " & @CRLF & _
"HEPATITA CU HVC " & @CRLF & _
"CIROZA HEPATICA -HVC CHILD A" & @CRLF & _
"Ac AntiHVC +, HEPATOSPLENOMEGALIE" & @CRLF & _
"HEPATITA CU HVC " & @CRLF & _
"HEPATITA CRONICA HVC" & @CRLF & _
"ANTICORPI ANTI-HVC+" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")