const regex = /((anticorpi|ac|ciroza).*?)?(hepatita (cr(onica)? )?(.*?))?(vh|hv|virus )([bcd])(.*?(vh|hv|virus )([bcd]))?/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((anticorpi|ac|ciroza).*?)?(hepatita (cr(onica)? )?(.*?))?(vh|hv|virus )([bcd])(.*?(vh|hv|virus )([bcd]))?', 'gi')
const str = `HEPATITA CRONICA CU VHC
HEPATITA CRONICA - VHC
HEPATITA CRONICA DE ETIOLOGIE MIXTA NUTRITIONALA SI VHC
HEPATITA CRONICA CU VHC.
HEPATITA CRONICA CU VHC.
HEPATITA CRONICA CU VHC
HEPATITA CRONICA - VHB
HEPATITA CRONICA CU VIRUS C
HEPATITA CRONICA
HEPATITA CRONICA CU VHB
HEPATITA CRONICA MEDICAMENTOASA.
HEPATITA DE ETIOLOGIE POSIBIL VIRALA IN APP
HEPATITA VIRUS C
HEPATITA CRONICA CU VHB
HEPATITA CRONICA CU VHC
Hepatita cr cu virus B
HEPATITA VIRUS C
HEPATITA VIRALA (VHA-####)
HEPATITA CRONICA VHB
HEPATITA CRONICA CU VHC
HEPATITA CRONICA- VHB
HEPATITA CRONICA CU VHC
HEPATITA CRONICA CU VHC(####)
HEPATITA CRONICA DE ETIOLOGIE NEPRECIZATA
HEPATITA CRONICA CU VHB
HEPATITA CRONICA VHC
HEPATITA CRONICA VIRALA CU VHC
HEPATITA VIRALA -VHC
HEPATITA CRONICA CU VHC
Hepatita cronica cu virus B
HEPATITA CRONICA CU VHB +VHC
HEPATITA CRONICA VHB+VHC
HEPATITA VIRALA C
HEPATITA CRONICA CU VHC
HEPATITA CRONICA CU VHB
HEPATITA CRONICA VHB+VHC
HEPATITA CRONICA CU VHB
HEPATITA B
Hepatita cronica.
HEPATITA CRONICA CU VHB
CIROZA HEPATICA SECUNDARA INFECTIEI CU VHB SI VHD
CIROZA HEPATICA VHB +VHD
CIROZA HEPATICA SECUNDARA INFECTIEI CU VHB SI VHD
HVB, HVC
HVB+ HVC
HVC + HVB
HEPATITA CU HVC
HEPATITA CRONICA HVC
HEPATITA CU HVC
CIROZA HEPATICA -HVC CHILD A
Ac AntiHVC +, HEPATOSPLENOMEGALIE
HEPATITA CU HVC
HEPATITA CRONICA HVC
ANTICORPI ANTI-HVC+
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}