package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^([0-9a-f]+)_(string[^_]+)_(string[^_]+)_(string[^_]+)_([0-9]+)_([0-9]+)_([^_]+)$`)
var str = `10E4558AA0_String1_String2_String3_0_100_12mo`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}