use strict;
my $str = 'TO MATCH:
<img src="images/vendor.png" alt="" > <img src="images/vendor.gif" class="box-bg-image" alt="" >
<img src="images/vendor-dp-20141009-flatware.jpg" class="box-bg-image" alt="" >
<img src="images/vendor-flatware.jpeg" class="box" alt="" >
<img src=\'images/vendor-flatware.jpeg\' class="box" >
<img alt="" src= \'images/vendor-flatware.jpeg\' alt="" >
<img src=\' images/vendor-flatware.jpg\' alt="" >
<img src=\' images/vendor-flatware.gif\' alt="" >
<img src=\' images/vendor-flatware.png \' alt="" >
<img src=\'../silverware.png\' alt="" >
<img class="box" src=\'images/vendor-watch.png\' alt="" >
<img src=" images/vendor-flatware.jpeg " alt="" >
< img src="images/vendor-flatware.jpeg " alt="" >
< img src="images/vendor-flatware.jpeg " alt="" >
<img src="vendor.gif" alt="">
NOT TO MATCH:
<img src="http://thirdpartycdn.com/image.jpg">
<img src=\'http://thirdpartycdn.com/image.png\'>
<img src="http://thirdpartycdn.com/image.gif" class="box-bg-image" alt="">
img src="images/vendor-flatware.jpeg "
<img src="images/vendorpng" alt="" >';
my $regex = qr/(?:'|")([^"':]*?\.(?:png|jpe?g|gif)[^'"]*(?=[^<]+?>))/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}