re = /(?:'|")([^"':]*?\.(?:png|jpe?g|gif)[^'"]*(?=[^<]+?>))/
str = 'TO MATCH:
<img src="images/vendor.png" alt="" > <img src="images/vendor.gif" class="box-bg-image" alt="" >
<img src="images/vendor-dp-20141009-flatware.jpg" class="box-bg-image" alt="" >
<img src="images/vendor-flatware.jpeg" class="box" alt="" >
<img src=\'images/vendor-flatware.jpeg\' class="box" >
<img alt="" src= \'images/vendor-flatware.jpeg\' alt="" >
<img src=\' images/vendor-flatware.jpg\' alt="" >
<img src=\' images/vendor-flatware.gif\' alt="" >
<img src=\' images/vendor-flatware.png \' alt="" >
<img src=\'../silverware.png\' alt="" >
<img class="box" src=\'images/vendor-watch.png\' alt="" >
<img src=" images/vendor-flatware.jpeg " alt="" >
< img src="images/vendor-flatware.jpeg " alt="" >
< img src="images/vendor-flatware.jpeg " alt="" >
<img src="vendor.gif" alt="">
NOT TO MATCH:
<img src="http://thirdpartycdn.com/image.jpg">
<img src=\'http://thirdpartycdn.com/image.png\'>
<img src="http://thirdpartycdn.com/image.gif" class="box-bg-image" alt="">
img src="images/vendor-flatware.jpeg "
<img src="images/vendorpng" alt="" >'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end