# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^data-(test|cy|jest).*$//gm;t' <<< "data-test
data-testid
data-test-id
data-cy
data-cyid
data-cy-id
data-jest
data-jestid
data-jest-id"