#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^data-(test|cy|jest).*$"
Local $sString = "data-test" & @CRLF & _
"data-testid" & @CRLF & _
"data-test-id" & @CRLF & _
"" & @CRLF & _
"data-cy" & @CRLF & _
"data-cyid" & @CRLF & _
"data-cy-id" & @CRLF & _
"" & @CRLF & _
"data-jest" & @CRLF & _
"data-jestid" & @CRLF & _
"data-jest-id"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)