using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)^(?=[a-z]+-[a-z]+$|\d+-\d+$)([a-z\d]+)-([a-z\d]+)$";
string input = @"1
3
10-15
17
A
b
XX-YY
z
5-A";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}