re = /(?i)^(?=[a-z]+-[a-z]+$|\d+-\d+$)([a-z\d]+)-([a-z\d]+)$/m
str = '1
3
10-15
17
A
b
XX-YY
z
5-A'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end