package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)[^\/]+(?:\/\/[^\/]*)*`)
var str = `text1/text2
text1/text2//text3
text1//text2
/text1//text2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}