re = /[^\/]+(?:\/\/[^\/]*)*/i
str = 'text1/text2
text1/text2//text3
text1//text2
/text1//text2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end