$re = '/(?:[^>=]|=\'[^\']*\'|="[^"]*"|=[^\'"][^\s>]*)*?\s*\Konclick\s*=([\'"]?)(.*?)\1(?:\s|$)/';
$str = 'onclick =\'unSelAll("FBtest11_6",this.value,this.id)\'
onmouseover=" onclick =\'This is not the droid you are looking for\' " onclick ="find me instead"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);