import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\n\\n)(^TY)";
final String string = "ER - lorem ipsum\n"
+ "TY - JOUR\n"
+ "CA - Berlin\n\n"
+ "TY - BOOK\n"
+ "CA - New York";
final String subst = "\\n$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}