using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*?-Publisher1$).+$";
string input = @"/subdir/subdir/.../Author1_-_Title1-(1234)-Publisher1
/subdir/subdir/.../Author2_-_Title2_(5678)-PUBLiSHER2
/subdir/subdir/.../Author3_-_Title3-4951-publisher3";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}