$re = '/^(?!.*?-Publisher1$).+$/m';
$str = '/subdir/subdir/.../Author1_-_Title1-(1234)-Publisher1
/subdir/subdir/.../Author2_-_Title2_(5678)-PUBLiSHER2
/subdir/subdir/.../Author3_-_Title3-4951-publisher3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);