using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\S)\d+\b(?![.,]\d)";
string input = @"My number is +12 345 678. 1.2 3,1 I have galaxy s3, its symbol 34abc.";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}