$re = '/(?<!\S)\d+\b(?![.,]\d)/';
$str = 'My number is +12 345 678. 1.2 3,1 I have galaxy s3, its symbol 34abc.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);