import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<b>(?:(?!<\\/?b>).)*?<\\/b>(?:(?!<\\/?b>).)*?<font color=darkslategray>.*?<\\/font>";
final String string = "naive\n"
+ "<b>na·ive</b><br><div style=\"padding-left:0.5em;\">(<VR><span style=\"color:#006400;font-style:italic\">or</span> <b>na·ïve</b></VR>) <font color=darkslategray>/nɑˈiːv, naıˈiːv/</font> <span style=\"color:#006400;font-style:italic\">adj</span> [<i>more ~; most ~</i>]<br></div><div style=\"padding-left:1em;\"><b>:</b> having or showing a lack of experience or knowledge <b>:</b> innocent or simple<br></div><div style=\"padding-left:1.5em;\"><font color=\"#004A95\">a <i>naive</i> belief that all people are good</font><br></div><div style=\"padding-left:1.5em;\"><font color=\"#004A95\">a <i>naive</i> view of the world</font><br></div><div style=\"padding-left:1.5em;\"><font color=\"#004A95\">I <i>naively</i> believed that we could fix the problem.</font><br></div><div style=\"padding-left:1em;\"><b>na·ïve·té</b> (<VR><span style=\"color:#006400;font-style:italic\">also</span> <b>na·ive·te</b> <span style=\"color:#006400;font-style:italic\">or</span> <b>na·ive·té</b></VR>) <font color=darkslategray>/nɑˌiːvˈteı, naıˌiːvˈteı/</font> <span style=\"color:#006400;font-style:italic\">noun</span> [<span style=\"color:#006400;font-style:italic\">noncount</span>]<br></div><div style=\"padding-left:1.5em;\"><font color=\"#004A95\">political <i>naïveté</i></font><br></div><div style=\"padding-left:1em;\"><b>na·ive·ty</b> (<VR><span style=\"color:#006400;font-style:italic\">also</span> <b>na·ïve·ty</b></VR>) <font color=darkslategray>/nɑˈiːvəti, naıˈiːvəti/</font> <span style=\"color:#006400;font-style:italic\">noun</span> [<span style=\"color:#006400;font-style:italic\">noncount</span>] <span style=\"color:#006400;font-style:italic\">chiefly Brit</span><br></div><div style=\"padding-left:1.5em;\"><font color=\"#004A95\">political <i>naïvety</i></font><br></div>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}