# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<b>(?:(?!<\/?b>).)*?<\/b>(?:(?!<\/?b>).)*?<font color=darkslategray>.*?<\/font>"
test_str = ("naive\n"
"<b>na·ive</b><br><div style=\"padding-left:0.5em;\">(<VR><span style=\"color:#006400;font-style:italic\">or</span> <b>na·ïve</b></VR>) <font color=darkslategray>/nɑˈiːv, naıˈiːv/</font> <span style=\"color:#006400;font-style:italic\">adj</span> [<i>more ~; most ~</i>]<br></div><div style=\"padding-left:1em;\"><b>:</b> having or showing a lack of experience or knowledge <b>:</b> innocent or simple<br></div><div style=\"padding-left:1.5em;\"><font color=\"#004A95\">a <i>naive</i> belief that all people are good</font><br></div><div style=\"padding-left:1.5em;\"><font color=\"#004A95\">a <i>naive</i> view of the world</font><br></div><div style=\"padding-left:1.5em;\"><font color=\"#004A95\">I <i>naively</i> believed that we could fix the problem.</font><br></div><div style=\"padding-left:1em;\"><b>na·ïve·té</b> (<VR><span style=\"color:#006400;font-style:italic\">also</span> <b>na·ive·te</b> <span style=\"color:#006400;font-style:italic\">or</span> <b>na·ive·té</b></VR>) <font color=darkslategray>/nɑˌiːvˈteı, naıˌiːvˈteı/</font> <span style=\"color:#006400;font-style:italic\">noun</span> [<span style=\"color:#006400;font-style:italic\">noncount</span>]<br></div><div style=\"padding-left:1.5em;\"><font color=\"#004A95\">political <i>naïveté</i></font><br></div><div style=\"padding-left:1em;\"><b>na·ive·ty</b> (<VR><span style=\"color:#006400;font-style:italic\">also</span> <b>na·ïve·ty</b></VR>) <font color=darkslategray>/nɑˈiːvəti, naıˈiːvəti/</font> <span style=\"color:#006400;font-style:italic\">noun</span> [<span style=\"color:#006400;font-style:italic\">noncount</span>] <span style=\"color:#006400;font-style:italic\">chiefly Brit</span><br></div><div style=\"padding-left:1.5em;\"><font color=\"#004A95\">political <i>naïvety</i></font><br></div>")
matches = re.finditer(regex, test_str, re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.