#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x) (?si)" & @CRLF & _
" ^ \s* UPDATE \s+ `mytable` \s+ SET \s+ `keyname` \s = \s 'keyvalue'" & @CRLF & _
" ( # (1 start)" & @CRLF & _
" (?>" & @CRLF & _
" , \s+ ` [A-Z_]+ `" & @CRLF & _
" (?# field name )" & @CRLF & _
" \s+ = \s+ " & @CRLF & _
" (?# equals value )" & @CRLF & _
" (?:" & @CRLF & _
" -? [0-9]+ " & @CRLF & _
" (?# an integer, possibly negative )" & @CRLF & _
" | " & @CRLF & _
" '" & @CRLF & _
" (?> [^'\\]+ | \\ . | '' )*" & @CRLF & _
" '" & @CRLF & _
" " & @CRLF & _
" # '" & @CRLF & _
" # [^'\\]* " & @CRLF & _
" # (?:" & @CRLF & _
" # (?: \\ . | '' )" & @CRLF & _
" # [^'\\]* " & @CRLF & _
" # )*" & @CRLF & _
" # '" & @CRLF & _
" " & @CRLF & _
" (?# a string in single quotes )" & @CRLF & _
" | NULL" & @CRLF & _
" (?# NULL )" & @CRLF & _
" )" & @CRLF & _
" )+" & @CRLF & _
" ) # (1 end)" & @CRLF & _
" (?# one or more such assignments )" & @CRLF & _
" \s+ WHERE \s+ `keyname` \s+ = \s+ 'keyvalue' $ " & @CRLF & _
""
Local $sString = "UPDATE `mytable`" & @CRLF & _
"SET `keyname` = 'keyvalue'," & @CRLF & _
"`Markup` =" & @CRLF & _
"'Lorem ipsum dolor sit amet, consectetur adipiscing elit." & @CRLF & _
"''Quisque vel mattis odio, quis iaculis sem.''" & @CRLF & _
"Nulla facilisi." & @CRLF & _
"Vestibulum ante ipsum primis in faucibus orci luctus et ultrices posuere" & @CRLF & _
"cubilia Curae; Fusce ut dui venenatis, maximus lorem eget, ornare ex." & @CRLF & _
"Aenean tempus pulvinar est, id fringilla enim sagittis id. Mauris finibus" & @CRLF & _
"cursus commodo.\r\n\r\n" & @CRLF & _
"Vestibulum ante ipsum primis in faucibus orci luctus et ultrices posuere" & @CRLF & _
"cubilia Curae; Fusce ut dui venenatis, maximus lorem eget, ornare ex." & @CRLF & _
"Aenean tempus pulvinar est, id fringilla enim sagittis id. Mauris finibus" & @CRLF & _
"cursus commodo.\r\n\r\n\r\n" & @CRLF & _
"\'Aenean in augue a est vulputate accumsan.\'" & @CRLF & _
"Phasellus nulla diam, laoreet a elit non, mattis finibus magna. Phasellus" & @CRLF & _
"faucibus iaculis mi sed pulvinar.\r\n" & @CRLF & _
"Aliquam non nisl ultricies, aliquam augue vitae, efficitur sapien." & @CRLF & _
"Etiam viverra, magna a laoreet sollicitudin, ipsum erat tincidunt sem, nec" & @CRLF & _
"faucibus enim tortor eget massa.Vestibulum ante ipsum primis in faucibus orci luctus et ultrices posuere" & @CRLF & _
"cubilia Curae; Fusce ut dui venenatis, maximus lorem eget, ornare ex." & @CRLF & _
"Aenean tempus pulvinar est, id fringilla enim sagittis id. Mauris finibus" & @CRLF & _
"cursus commodo.\r\n\r\n" & @CRLF & _
"Vestibulum ante ipsum primis in faucibus orci luctus et ultrices posuere" & @CRLF & _
"cubilia Curae; Fusce ut dui venenatis, maximus lorem eget, ornare ex." & @CRLF & _
"Aenean tempus pulvinar est, id fringilla enim sagittis id. Mauris finibus" & @CRLF & _
"cursus commodo.\r\n\r\n\r\n" & @CRLF & _
"\'Aenean in augue a est vulputate accumsan.\'" & @CRLF & _
"Phasellus nulla diam, laoreet a elit non, mattis finibus magna. Phasellus" & @CRLF & _
"faucibus iaculis mi sed pulvinar.\r\n" & @CRLF & _
"Aliquam non nisl ultricies, aliquam augue vitae, efficitur sapien." & @CRLF & _
"Etiam viverra, magna a laoreet sollicitudin, ipsum erat tincidunt sem, nec" & @CRLF & _
"faucibus enim tortor eget massa.Vestibulum ante ipsum primis in faucibus orci luctus et ultrices posuere" & @CRLF & _
"cubilia Curae; Fusce ut dui venenatis, maximus lorem eget, ornare ex." & @CRLF & _
"Aenean tempus pulvinar est, id fringilla enim sagittis id. Mauris finibus" & @CRLF & _
"cursus commodo.\r\n\r\n" & @CRLF & _
"Vestibulum ante ipsum primis in faucibus orci luctus et ultrices posuere" & @CRLF & _
"cubilia Curae; Fusce ut dui venenatis, maximus lorem eget, ornare ex." & @CRLF & _
"Aenean tempus pulvinar est, id fringilla enim sagittis id. Mauris finibus" & @CRLF & _
"cursus commodo.\r\n\r\n\r\n" & @CRLF & _
"\'Aenean in augue a est vulputate accumsan.\'" & @CRLF & _
"Phasellus nulla diam, laoreet a elit non, mattis finibus magna. Phasellus" & @CRLF & _
"faucibus iaculis mi sed pulvinar.\r\n" & @CRLF & _
"Aliquam non nisl ultricies, aliquam augue vitae, efficitur sapien." & @CRLF & _
"Etiam viverra, magna a laoreet sollicitudin, ipsum erat tincidunt sem, nec" & @CRLF & _
"faucibus enim tortor eget massa.Vestibulum ante ipsum primis in faucibus orci luctus et ultrices posuere" & @CRLF & _
"cubilia Curae; Fusce ut dui venenatis, maximus lorem eget, ornare ex." & @CRLF & _
"Aenean tempus pulvinar est, id fringilla enim sagittis id. Mauris finibus" & @CRLF & _
"cursus commodo.\r\n\r\n" & @CRLF & _
"Vestibulum ante ipsum primis in faucibus orci luctus et ultrices posuere" & @CRLF & _
"cubilia Curae; Fusce ut dui venenatis, maximus lorem eget, ornare ex." & @CRLF & _
"Aenean tempus pulvinar est, id fringilla enim sagittis id. Mauris finibus" & @CRLF & _
"cursus commodo.\r\n\r\n\r\n" & @CRLF & _
"\'Aenean in augue a est vulputate accumsan.\'" & @CRLF & _
"Phasellus nulla diam, laoreet a elit non, mattis finibus magna. Phasellus" & @CRLF & _
"faucibus iaculis mi sed pulvinar.\r\n" & @CRLF & _
"Aliquam non nisl ultricies, aliquam augue vitae, efficitur sapien." & @CRLF & _
"Etiam viverra, magna a laoreet sollicitudin, ipsum erat tincidunt sem, nec" & @CRLF & _
"faucibus enim tortor eget massa.Vestibulum ante ipsum primis in faucibus orci luctus et ultrices posuere" & @CRLF & _
"cubilia Curae; Fusce ut dui venenatis, maximus lorem eget, ornare ex." & @CRLF & _
"Aenean tempus pulvinar est, id fringilla enim sagittis id. Mauris finibus" & @CRLF & _
"cursus commodo.\r\n\r\n" & @CRLF & _
"Vestibulum ante ipsum primis in faucibus orci luctus et ultrices posuere" & @CRLF & _
"cubilia Curae; Fusce ut dui venenatis, maximus lorem eget, ornare ex." & @CRLF & _
"Aenean tempus pulvinar est, id fringilla enim sagittis id. Mauris finibus" & @CRLF & _
"cursus commodo.\r\n\r\n\r\n" & @CRLF & _
"\'Aenean in augue a est vulputate accumsan.\'" & @CRLF & _
"Phasellus nulla diam, laoreet a elit non, mattis finibus magna. Phasellus" & @CRLF & _
"faucibus iaculis mi sed pulvinar.\r\n" & @CRLF & _
"Aliquam non nisl ultricies, aliquam augue vitae, efficitur sapien." & @CRLF & _
"Etiam viverra, magna a laoreet sollicitudin, ipsum erat tincidunt sem, nec" & @CRLF & _
"faucibus enim tortor eget massa.Vestibulum ante ipsum primis in faucibus orci luctus et ultrices posuere" & @CRLF & _
"cubilia Curae; Fusce ut dui venenatis, maximus lorem eget, ornare ex." & @CRLF & _
"Aenean tempus pulvinar est, id fringilla enim sagittis id. Mauris finibus" & @CRLF & _
"cursus commodo.\r\n\r\n" & @CRLF & _
"Vestibulum ante ipsum primis in faucibus orci luctus et ultrices posuere" & @CRLF & _
"cubilia Curae; Fusce ut dui venenatis, maximus lorem eget, ornare ex." & @CRLF & _
"Aenean tempus pulvinar est, id fringilla enim sagittis id. Mauris finibus" & @CRLF & _
"cursus commodo.\r\n\r\n\r\n" & @CRLF & _
"\'Aenean in augue a est vulputate accumsan.\'" & @CRLF & _
"Phasellus nulla diam, laoreet a elit non, mattis finibus magna. Phasellus" & @CRLF & _
"faucibus iaculis mi sed pulvinar.\r\n" & @CRLF & _
"Aliquam non nisl ultricies, aliquam augue vitae, efficitur sapien." & @CRLF & _
"Etiam viverra, magna a laoreet sollicitudin, ipsum erat tincidunt sem, nec" & @CRLF & _
"faucibus enim tortor eget massa." & @CRLF & _
"Nunc nisi orci, lacinia vitae dictum et, vestibulum sed metus. '," & @CRLF & _
"`From_Date` = NULL," & @CRLF & _
"`To_Date` = NULL," & @CRLF & _
"`Foo` = ''," & @CRLF & _
"`Box_Colour` = NULL," & @CRLF & _
"`Modification_Date` = '2016-09-08 12:30:47'," & @CRLF & _
"`Modified_User` = 1," & @CRLF & _
"`Modified_IP` = '192.168.1.1'" & @CRLF & _
"WHERE `keyname` = 'keyvalue'"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")