# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
(?si)
^ \s* UPDATE \s+ `mytable` \s+ SET \s+ `keyname` \s = \s 'keyvalue'
( # (1 start)
(?>
, \s+ ` [A-Z_]+ `
(?# field name )
\s+ = \s+
(?# equals value )
(?:
-? [0-9]+
(?# an integer, possibly negative )
|
'
(?> [^'\\]+ | \\ . | '' )*
'
# '
# [^'\\]*
# (?:
# (?: \\ . | '' )
# [^'\\]*
# )*
# '
(?# a string in single quotes )
| NULL
(?# NULL )
)
)+
) # (1 end)
(?# one or more such assignments )
\s+ WHERE \s+ `keyname` \s+ = \s+ 'keyvalue' $
"""
test_str = ("UPDATE `mytable`\n"
"SET `keyname` = 'keyvalue',\n"
"`Markup` =\n"
"'Lorem ipsum dolor sit amet, consectetur adipiscing elit.\n"
"''Quisque vel mattis odio, quis iaculis sem.''\n"
"Nulla facilisi.\n"
"Vestibulum ante ipsum primis in faucibus orci luctus et ultrices posuere\n"
"cubilia Curae; Fusce ut dui venenatis, maximus lorem eget, ornare ex.\n"
"Aenean tempus pulvinar est, id fringilla enim sagittis id. Mauris finibus\n"
"cursus commodo.\\r\\n\\r\\n\n"
"Vestibulum ante ipsum primis in faucibus orci luctus et ultrices posuere\n"
"cubilia Curae; Fusce ut dui venenatis, maximus lorem eget, ornare ex.\n"
"Aenean tempus pulvinar est, id fringilla enim sagittis id. Mauris finibus\n"
"cursus commodo.\\r\\n\\r\\n\\r\\n\n"
"\\'Aenean in augue a est vulputate accumsan.\\'\n"
"Phasellus nulla diam, laoreet a elit non, mattis finibus magna. Phasellus\n"
"faucibus iaculis mi sed pulvinar.\\r\\n\n"
"Aliquam non nisl ultricies, aliquam augue vitae, efficitur sapien.\n"
"Etiam viverra, magna a laoreet sollicitudin, ipsum erat tincidunt sem, nec\n"
"faucibus enim tortor eget massa.Vestibulum ante ipsum primis in faucibus orci luctus et ultrices posuere\n"
"cubilia Curae; Fusce ut dui venenatis, maximus lorem eget, ornare ex.\n"
"Aenean tempus pulvinar est, id fringilla enim sagittis id. Mauris finibus\n"
"cursus commodo.\\r\\n\\r\\n\n"
"Vestibulum ante ipsum primis in faucibus orci luctus et ultrices posuere\n"
"cubilia Curae; Fusce ut dui venenatis, maximus lorem eget, ornare ex.\n"
"Aenean tempus pulvinar est, id fringilla enim sagittis id. Mauris finibus\n"
"cursus commodo.\\r\\n\\r\\n\\r\\n\n"
"\\'Aenean in augue a est vulputate accumsan.\\'\n"
"Phasellus nulla diam, laoreet a elit non, mattis finibus magna. Phasellus\n"
"faucibus iaculis mi sed pulvinar.\\r\\n\n"
"Aliquam non nisl ultricies, aliquam augue vitae, efficitur sapien.\n"
"Etiam viverra, magna a laoreet sollicitudin, ipsum erat tincidunt sem, nec\n"
"faucibus enim tortor eget massa.Vestibulum ante ipsum primis in faucibus orci luctus et ultrices posuere\n"
"cubilia Curae; Fusce ut dui venenatis, maximus lorem eget, ornare ex.\n"
"Aenean tempus pulvinar est, id fringilla enim sagittis id. Mauris finibus\n"
"cursus commodo.\\r\\n\\r\\n\n"
"Vestibulum ante ipsum primis in faucibus orci luctus et ultrices posuere\n"
"cubilia Curae; Fusce ut dui venenatis, maximus lorem eget, ornare ex.\n"
"Aenean tempus pulvinar est, id fringilla enim sagittis id. Mauris finibus\n"
"cursus commodo.\\r\\n\\r\\n\\r\\n\n"
"\\'Aenean in augue a est vulputate accumsan.\\'\n"
"Phasellus nulla diam, laoreet a elit non, mattis finibus magna. Phasellus\n"
"faucibus iaculis mi sed pulvinar.\\r\\n\n"
"Aliquam non nisl ultricies, aliquam augue vitae, efficitur sapien.\n"
"Etiam viverra, magna a laoreet sollicitudin, ipsum erat tincidunt sem, nec\n"
"faucibus enim tortor eget massa.Vestibulum ante ipsum primis in faucibus orci luctus et ultrices posuere\n"
"cubilia Curae; Fusce ut dui venenatis, maximus lorem eget, ornare ex.\n"
"Aenean tempus pulvinar est, id fringilla enim sagittis id. Mauris finibus\n"
"cursus commodo.\\r\\n\\r\\n\n"
"Vestibulum ante ipsum primis in faucibus orci luctus et ultrices posuere\n"
"cubilia Curae; Fusce ut dui venenatis, maximus lorem eget, ornare ex.\n"
"Aenean tempus pulvinar est, id fringilla enim sagittis id. Mauris finibus\n"
"cursus commodo.\\r\\n\\r\\n\\r\\n\n"
"\\'Aenean in augue a est vulputate accumsan.\\'\n"
"Phasellus nulla diam, laoreet a elit non, mattis finibus magna. Phasellus\n"
"faucibus iaculis mi sed pulvinar.\\r\\n\n"
"Aliquam non nisl ultricies, aliquam augue vitae, efficitur sapien.\n"
"Etiam viverra, magna a laoreet sollicitudin, ipsum erat tincidunt sem, nec\n"
"faucibus enim tortor eget massa.Vestibulum ante ipsum primis in faucibus orci luctus et ultrices posuere\n"
"cubilia Curae; Fusce ut dui venenatis, maximus lorem eget, ornare ex.\n"
"Aenean tempus pulvinar est, id fringilla enim sagittis id. Mauris finibus\n"
"cursus commodo.\\r\\n\\r\\n\n"
"Vestibulum ante ipsum primis in faucibus orci luctus et ultrices posuere\n"
"cubilia Curae; Fusce ut dui venenatis, maximus lorem eget, ornare ex.\n"
"Aenean tempus pulvinar est, id fringilla enim sagittis id. Mauris finibus\n"
"cursus commodo.\\r\\n\\r\\n\\r\\n\n"
"\\'Aenean in augue a est vulputate accumsan.\\'\n"
"Phasellus nulla diam, laoreet a elit non, mattis finibus magna. Phasellus\n"
"faucibus iaculis mi sed pulvinar.\\r\\n\n"
"Aliquam non nisl ultricies, aliquam augue vitae, efficitur sapien.\n"
"Etiam viverra, magna a laoreet sollicitudin, ipsum erat tincidunt sem, nec\n"
"faucibus enim tortor eget massa.Vestibulum ante ipsum primis in faucibus orci luctus et ultrices posuere\n"
"cubilia Curae; Fusce ut dui venenatis, maximus lorem eget, ornare ex.\n"
"Aenean tempus pulvinar est, id fringilla enim sagittis id. Mauris finibus\n"
"cursus commodo.\\r\\n\\r\\n\n"
"Vestibulum ante ipsum primis in faucibus orci luctus et ultrices posuere\n"
"cubilia Curae; Fusce ut dui venenatis, maximus lorem eget, ornare ex.\n"
"Aenean tempus pulvinar est, id fringilla enim sagittis id. Mauris finibus\n"
"cursus commodo.\\r\\n\\r\\n\\r\\n\n"
"\\'Aenean in augue a est vulputate accumsan.\\'\n"
"Phasellus nulla diam, laoreet a elit non, mattis finibus magna. Phasellus\n"
"faucibus iaculis mi sed pulvinar.\\r\\n\n"
"Aliquam non nisl ultricies, aliquam augue vitae, efficitur sapien.\n"
"Etiam viverra, magna a laoreet sollicitudin, ipsum erat tincidunt sem, nec\n"
"faucibus enim tortor eget massa.\n"
"Nunc nisi orci, lacinia vitae dictum et, vestibulum sed metus. ',\n"
"`From_Date` = NULL,\n"
"`To_Date` = NULL,\n"
"`Foo` = '',\n"
"`Box_Colour` = NULL,\n"
"`Modification_Date` = '2016-09-08 12:30:47',\n"
"`Modified_User` = 1,\n"
"`Modified_IP` = '192.168.1.1'\n"
"WHERE `keyname` = 'keyvalue'")
matches = re.search(regex, test_str, re.VERBOSE)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.