import re
regex = re.compile(r"[0-9]+[ \t\r]+(\w|\.|\-)+[ \t\r]+[0-9]+([ \t\r]+(\w|\.|\-)+[ \t\r]+\-[ \t\r]+\w+|)(\n|\r|)+")
test_str = ("0 coralxib42 0 coralxib42-ib0 - MEMBER\n"
"1 coralxib43 0 coralxib43-ib0 - MEMBER\n"
"128 coralxib44 0 coralxib44-ib0 - CF\n"
"129 coralxib45 0 coralxib45-ib0 - CF\n"
"0 coralpib241 0 - - MEMBER\n"
"1 coralpib242 0 - - MEMBER\n"
"128 coralpib243 0 - - CF\n"
"129 coralpib244 0 - - CF\n"
"cskd;ksd ksalkd;lksakd sad'lj\n"
"020 - 29 \n"
"0 coralpib241 0\n"
"1 coralpib242 0\n"
"128 coralpib243 0\n"
"129 coralpib244 0")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")