const regex = /<link(?=[^<>]*?opensearch)(?:[^h]+|h(?!ref))*+href=["']?\K([^<>'"\s]+(?:\/(?!>)|\b))(?=[^<>]*>)/igm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<link(?=[^<>]*?opensearch)(?:[^h]+|h(?!ref))*+href=["\']?\\K([^<>\'"\\s]+(?:\\\/(?!>)|\\b))(?=[^<>]*>)', 'igm')
const str = `This should succeed:
<link rel="search" type="application/opensearchdescription+xml" href="http://example.com/tsr-opensearch/" title="" />
<link rel="search" type="application/opensearchdescription+xml" href="http://www.example.com/search.xml" title="" />
<link rel="search" type="application/opensearchdescription+xml" href="/search.xml" title="" />
<link rel="search" type="application/opensearchdescription+xml" href="search.xml" title="" />
<link rel="search" type="application/opensearchdescription+xml" href=".search.xml" title="" />
<link rel="search" type="application/opensearchdescription+xml" href="./search.xml" title="" />
<link rel="search" type="application/opensearchdescription+xml" href=".search.xml" title="" />
<link rel="search" type="application/opensearchdescription+xml" href='http://www.example.com/search.xml' title="" />
<link rel="search" type="application/opensearchdescription+xml" href=http://www.example.com/search.xml title="" />
<link rel="search" type="application/opensearchdescription+xml" href=http://www.example.com/search.xml>
<link rel="search" type="application/opensearchdescription+xml" href=http://www.example.com/search.xml />
<link rel="search" type="application/opensearchdescription+xml" href=http://www.example.com/search.xml />
<link rel="search" type="application/opensearchdescription+xml" href=http://www.example.com/search.xml/>
<link rel="search" type="application/opensearchdescription+xml" href=http://www.example.com/dsfdsf/search.xml />
<link rel="search" type="application/opensearchdescription+xml" href=http://www.example.com/search.xml/ />
<link rel="search" type="application/opensearchdescription+xml" href=http://www.example.com/search.xml/ />
<link rel="search" type="application/opensearchdescription+xml" href=http://href.example.com/search.xml/ />
<link rel="search" type="application/opensearchdescription+xml" hre href=http://href.example.com/search.xml/ />
<link rel="search" type="application/opensearchdescription+xml" ref="adfsf" href=http://href.example.com/search.xml/ />
Should fail:
<link rel="stylesheet" type="text/css" href="theme.css">
<link rel="search" type="application/opensearchdescription+xml" href= http://www.example.com/search.xml />
<link rel="search" type="application/opensearchdescription+xml" href= http://www.example.com/search.xml>
link rel="search" type="application/opensearchdescription+xml" href=http://www.example.com/search.xml>
link rel="search" type="application/opensearchdescription+xml" href=http://www.example.com/search.xml />
<link rel="search" type="application/opensearchdescription+xml" href=http://www.example.com/search.xml`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}