import Foundation
let pattern = #"<link(?=[^<>]*?opensearch)(?:[^h]+|h(?!ref))*+href=["']?\K([^<>'"\s]+(?:\/(?!>)|\b))(?=[^<>]*>)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive, .allowCommentsAndWhitespace])
let testString = #"""
This should succeed:
<link rel="search" type="application/opensearchdescription+xml" href="http://example.com/tsr-opensearch/" title="" />
<link rel="search" type="application/opensearchdescription+xml" href="http://www.example.com/search.xml" title="" />
<link rel="search" type="application/opensearchdescription+xml" href="/search.xml" title="" />
<link rel="search" type="application/opensearchdescription+xml" href="search.xml" title="" />
<link rel="search" type="application/opensearchdescription+xml" href=".search.xml" title="" />
<link rel="search" type="application/opensearchdescription+xml" href="./search.xml" title="" />
<link rel="search" type="application/opensearchdescription+xml" href=".search.xml" title="" />
<link rel="search" type="application/opensearchdescription+xml" href='http://www.example.com/search.xml' title="" />
<link rel="search" type="application/opensearchdescription+xml" href=http://www.example.com/search.xml title="" />
<link rel="search" type="application/opensearchdescription+xml" href=http://www.example.com/search.xml>
<link rel="search" type="application/opensearchdescription+xml" href=http://www.example.com/search.xml />
<link rel="search" type="application/opensearchdescription+xml" href=http://www.example.com/search.xml />
<link rel="search" type="application/opensearchdescription+xml" href=http://www.example.com/search.xml/>
<link rel="search" type="application/opensearchdescription+xml" href=http://www.example.com/dsfdsf/search.xml />
<link rel="search" type="application/opensearchdescription+xml" href=http://www.example.com/search.xml/ />
<link rel="search" type="application/opensearchdescription+xml" href=http://www.example.com/search.xml/ />
<link rel="search" type="application/opensearchdescription+xml" href=http://href.example.com/search.xml/ />
<link rel="search" type="application/opensearchdescription+xml" hre href=http://href.example.com/search.xml/ />
<link rel="search" type="application/opensearchdescription+xml" ref="adfsf" href=http://href.example.com/search.xml/ />
Should fail:
<link rel="stylesheet" type="text/css" href="theme.css">
<link rel="search" type="application/opensearchdescription+xml" href= http://www.example.com/search.xml />
<link rel="search" type="application/opensearchdescription+xml" href= http://www.example.com/search.xml>
link rel="search" type="application/opensearchdescription+xml" href=http://www.example.com/search.xml>
link rel="search" type="application/opensearchdescription+xml" href=http://www.example.com/search.xml />
<link rel="search" type="application/opensearchdescription+xml" href=http://www.example.com/search.xml
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)