#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)(^(.*)\s+(\d\d\.\d\d\.)$|^(\d\d:\d\d)\s+(.*)\s+(\d+\.\d\d)$)+"
Local $sString = "WGS AUFFUELLUNGEN" & @CRLF & _
"ADMIN1 23.03." & @CRLF & _
"17:09 -20- 1500.00" & @CRLF & _
"17:10 JD20 560.00" & @CRLF & _
"17:11 -2.0- 112.00" & @CRLF & _
"ADMIN1 24.03." & @CRLF & _
"14:51 JD50 500.00" & @CRLF & _
"ADMIN2 27.03." & @CRLF & _
"08:58 JD50 500.00" & @CRLF & _
"----------------------" & @CRLF & _
" 3172.00"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")