# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(^(.*)\s+(\d\d\.\d\d\.)$|^(\d\d:\d\d)\s+(.*)\s+(\d+\.\d\d)$)+"
test_str = ("WGS AUFFUELLUNGEN\n"
"ADMIN1 23.03.\n"
"17:09 -20- 1500.00\n"
"17:10 JD20 560.00\n"
"17:11 -2.0- 112.00\n"
"ADMIN1 24.03.\n"
"14:51 JD50 500.00\n"
"ADMIN2 27.03.\n"
"08:58 JD50 500.00\n"
"----------------------\n"
" 3172.00")
matches = re.finditer(regex, test_str, re.IGNORECASE | re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.