#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\{([^\}\|]*)(\|\()?\}"
Local $sString = "IX: {Series|(} {9}" & @CRLF & _
"IX: {Series!geometric!infinite} {13}" & @CRLF & _
"IX: {Series!geometric|(} {13}" & @CRLF & _
"IX: {Series!geometric!finite|(} {13}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")