$re = '/\{([^\}\|]*)(\|\()?\}/';
$str = 'IX: {Series|(} {9}
IX: {Series!geometric!infinite} {13}
IX: {Series!geometric|(} {13}
IX: {Series!geometric!finite|(} {13}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);