$re = '/#(?!.*\.0)/im';
$str = '###,##.##0.0########
';
$subst = "0";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;