import re
regex = re.compile(r"#(?!.*\.0)", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("###,##.##0.0######## \n")
subst = "0"
result = regex.sub(subst, test_str)
if result:
print(result)