import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(X=[0-9]+?)(?:.+?(Y=[0-9]+?).+?|.+?)$";
final String string = "X=1 a b c Y=5 a bb aa\n"
+ "X=2 aa ccc d\n"
+ "X=3 ccc Y=9 d ee ff";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}