$re = '/^(X=[0-9]+?)(?:.+?(Y=[0-9]+?).+?|.+?)$/m';
$str = 'X=1 a b c Y=5 a bb aa
X=2 aa ccc d
X=3 ccc Y=9 d ee ff';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);