$re = '/^\d+\s<([A-Z]+)>\s(\d+\s)(\2)+<\/(\1)>$/m';
$str = '1234 <CIRCLE> 12 12 12 </CIRCLE>
1234 <RECTANGLE> 12 12 12 12 </RECTANGLE>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);