#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[\s\S]*\K(<p>)"
Local $sString = "<p>First paragraph</p>" & @CRLF & _
"<p>Second paragraph</p>" & @CRLF & _
"<p>Third paragraph</p>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")