package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(<[^>]*>|[^<>]+)`)
var str = `list1<^0.1>list2<#0.2>list3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}