$re = '/(<[^>]*>|[^<>]+)/m';
$str = 'list1<^0.1>list2<#0.2>list3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);