use strict;
my $str = '1234756756777890';
my $regex = qr/(?<=\d{4})\d(?=\d{4})/mp;
my $subst = 'X';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";