$re = '/(?<=\d{4})\d(?=\d{4})/m';
$str = '1234756756777890';
$subst = "X";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;