using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s-\s\S+(?=\.)";
string substitution = @"";
string input = @"SongName - www.sitename.com.mp3
song name - www.snakemp3.xx.com.mp3";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}