const regex = /\s-\s\S+(?=\.)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s-\\s\\S+(?=\\.)', 'gm')
const str = `SongName - www.sitename.com.mp3
song name - www.snakemp3.xx.com.mp3`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);