$re = '/"(?!\s)(?=(?:(?:[^"]*"){2})*[^"]*$)|\'(?!\s)(?=(?:(?:[^\']*\'){2})*[^\']*$)/';
$str = 'first " closing double quote" should not match, but "the second one"should.
first \' closing double quote\' should not match, but \'the second one\'should.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);