re = /"(?!\s)(?=(?:(?:[^"]*"){2})*[^"]*$)|'(?!\s)(?=(?:(?:[^']*'){2})*[^']*$)/
str = 'first " closing double quote" should not match, but "the second one"should.
first \' closing double quote\' should not match, but \'the second one\'should.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end