$re = '/^(?!.*_).*\.txt$/m';
$str = 'somepath/testFile.txt
somepath/testFile_test.txt
somepath/testFile.txtTEMP';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);