$re = '/\(([^()]+)\)/m';
$str = '(((Thermal) WN RR) AND ((Energy) SS AB)), Text only
((Thermal) WN TR), ((((((Thermal) WN RR)), (((Thermal) WN RR) AND ((Energy) SS AB)) OR (((Thermal) WN RR)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);