re = /\(([^()]+)\)/m
str = '(((Thermal) WN RR) AND ((Energy) SS AB)), Text only
((Thermal) WN TR), ((((((Thermal) WN RR)), (((Thermal) WN RR) AND ((Energy) SS AB)) OR (((Thermal) WN RR)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end