$re = '/^[\s\S]*(?:^|\r?\n)\s+(\d+)(?![\s\S]*(\r?\n){2})/m';
$str = 'this is test
1. this is test
2. this is test
3. this is test
this is test
1. this test
2. this is test 5
this is test';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);